DNS forwarding is failing for some regions

Incident Report for StoreConnect Status

Resolved

DNS forwarding issue has been resolved for all regions.

Root cause: The DNS targets handling multiple regions have expired and caused some regions to be pointed to a parked domain. Once found, resolution by the operations team was immediate. However, DNS servers took a while to propagate the change causing some apps to be intermittently down.

System checks confirm that DNS propagations are complete and systems are 100% operational.
Posted Oct 03, 2025 - 15:42 AEST

Update

We are continuing to work on a fix for this issue.
Posted Oct 03, 2025 - 13:11 AEST

Identified

Issue has been identified and engineers are working on the fix.
Posted Oct 03, 2025 - 13:11 AEST
This incident affected: Stores (Store Availability, Search, Geolocation Service).