StoreConnect Installation Fails to Complete

Incident Report for StoreConnect Status

Resolved

The DNS issue experienced with our upstream provider has been resolved. The StoreConnect installer is now operating as expected.
Posted Sep 17, 2025 - 22:56 AEST

Monitoring

Our upstream provider has applied a fix to resolve the issue. Situation is being monitored until performance degradation is resolved for all users.
Posted Sep 17, 2025 - 19:25 AEST

Investigating

Our upstream provider is currently experiencing issues with domain provisioning, this may prevent store installations from completing.

We are actively monitoring the situation and will share updates as they become available.
Posted Sep 17, 2025 - 17:12 AEST
This incident affected: StoreConnect Installer.