StoreConnect Site Not Reachable

Incident Report for StoreConnect Status

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 13:00 AEDT

Monitoring

StoreConnect Installer and all stores are back online. Monitoring is in progress to confirm system stability and performance.
Posted Oct 21, 2025 - 07:33 AEDT

Update

The fix is still in progress; recovery is expanding as more stores come back online.
Posted Oct 21, 2025 - 06:05 AEDT

Update

Our service provider is actively working on the issue, and we’re starting to see some of our stores come back online.
Posted Oct 21, 2025 - 05:06 AEDT

Identified

This incident is part of a multi-cloud Service Disruption. More details can be found here:

https://status.salesforce.com/generalmessages/20000226
Posted Oct 21, 2025 - 04:47 AEDT

Update

The outage is currently impacting StoreConnect Installer. New store installations will fail until the issue is resolved.
Posted Oct 21, 2025 - 03:26 AEDT

Update

We are in coordination with our service provider, we will provide updates once available.
Posted Oct 21, 2025 - 02:40 AEDT

Investigating

We are experiencing an outage from one of our service providers. This may result in stores not being reachable.

We are actively monitoring the situation and will provide regular updates until the situation is resolved.
Posted Oct 21, 2025 - 01:39 AEDT
This incident affected: Stores (Store Availability) and StoreConnect Installer.